wiki:esp_dev_arduino_ide

ESP-WROOM-02開発ボードをArduino IDEで開発する方法

​ESP-WROOM-02開発ボードをArduino IDEで開発するための方法を記します。

1.Arduino IDEにESP8266ボードを追加

バージョンが1.6.X系のArduino IDEを用意します。今回は1.6.7を使用しました。(2016.02.01現在)
まずファイル→環境設定を開きます。
Settingタブ内のAdditional Boards Manager URLsに次のURLを入力します。
​http://arduino.esp8266.com/stable/package_esp8266com_index.json


次に、ツール→マイコンボード→ボードマネージャーを選択します。
esp8266という項目があるはずなので、バージョンを選択してインストールボタンを押します。
ここではver 2.0.0を選択しました。


インストール完了
これでESP-WROOM-02開発ボードをArduino IDEで開発できるようになりました。

2.ボード選択

ツール→マイコンボード→Generic ESP8266 Moduleを選択します。

次のように設定をします。

Flash Mode QIO
Flash Frequency 40MHz
Upload Using Serial
CPU Frequency 80MHz
Flash Size 2M(1M SPIFFS)
Reset Method nodemcu
Upload Speed 115200
シリアルポート 開発ボードのシリアルポート番号

注 Flashのサイズが4MBから2MBに変更になったため、4M(3M SPIFFS)から2M(1M SPIFFS)に変更しました。画像は古いままです。(2017/09/25)
注 Flashのサイズが4MBから2MBに変更になったため、4M(3M SPIFFS)から2M(1M SPIFFS)に変更しました。画像は古いままです。(2017/09/25)

3.スケッチ書き込み

スケッチを作成して、買い込みボタンを押せば開発ボードにスケッチが書き込まれます。
開発ボードにはリセットボタンとIO0のモード切替ボタンが付いていますが、Reset Methodをnodemcuに設定していればボタンの操作をしなくとも、自動的に書き込みを行います。


「マイコンボードへの書き込みが完了しました。」と表示されれば終了です。

Last modified 7 years ago Last modified on Sep 25, 2017, 6:54:04 PM

Attachments (11)

Download all attachments as: .zip

Note: See TracWiki for help on using the wiki.